Please check out the English help page (or the German Hilfe) first before posting.

Notifications
Clear all

[Solved] Client Network configuration (iMAC OS X 10.15.7)  

  RSS

Eminent Member
Joined: 9 Monaten ago
Posts: 28
23/10/2020 6:01 pm  

My network settings on the iMAC must still be faulty because the traceroute still points to my Fritzbox first.(Checked with network utility, Traceroute to www.eblocker.com)

I have trouble assigning the correct settings to the terms.

Here my network settings after changing to the individual mode on eblocker:

IP Client (iMAC): 192.168.178.27

IP Router/Gateway (Fritzbox Cable 6591): 192.168.178.1

IP eblocker (Raspi 3): 192.168.178.44

 

The System Preferences on my iMAC are at the Moment:

Ethernet

IP4 konfigurieren: Manuell

IP Adresse: 192.168.178.27

Teilnetzmaske: the same like in eblocker

Router: 192.168.178.1

DNS Server: 192.168.178.44

Such Domains: fritz.box

IPv6 Adresse: 2a02:....:.....:....:....:....:....:1135    (I know, that I have to try disable this, but i don't know how, any ideas?)

 

Further Options:

DNS Server: 192.168.178.44     (Here I'm not sure)

Such Domain: Fritz.Box             (Here I'm not sure)

 

What are the right settings that I have to do in my client?

At Fritzbox 6591 the DHCP Server for IPv4 Adresses is disabled. (But not at this moment. When I do this, I'm not able to go online - I don't know why....)

 


Quote
Topic Tags
Member
Joined: 12 Monaten ago
Posts: 598
23/10/2020 10:05 pm  

Set you macOS to a fixed IP as follows:

IP 192.168.178.27

Mask 255.255.255.0

DNS: 192.168.178.44 (the IP address of eBlocker)

Gateway: 192.168.178.44 (the IP address of eBlocker)

TCP/IP basics: The Gateway (always) tells the client (macOS) where to send packages to that are meant for the Internet. So set Gateway (and DNS) to eBlockers IP and it should work (if eBlocker‘s Gateway is set to your router‘s IP: 192.168.178.1 - that‘s where eBlocker sends the packages to). Clear?

Try „tracert 1.1.1.1“ to check if eBlocker comes first, then your router. 

THEN try „tracert www.eblocker.org“ to check that DNS resolution works fine too.

BTW: if eBlocker is the DHCP server and the client is set to get it‘s config from the DHCP server (no fixed IP), then eBlocker‘s DHCP server will automatically provide correct settings to the client. Client maybe needs to be rebooted to get settings (or pull Ethernet cable).

If all this does not work: post screenshots of your settings, as I‘m a bit confused which of your discussed settings belong to which device (i.e. what‘s „further options“ ??).

Regarding IPv6 (your other post): search for „disable IPv6 macOS“. I get trillions of of answers. Just follow. (I‘m on Win and can‘t help.) Reading helps!! (no need to disable IPv6 on router if it‘s disabled in all clients!)

THX!


ReplyQuote
Eminent Member
Joined: 9 Monaten ago
Posts: 28
26/10/2020 1:26 pm  

@Random:

Last night, after many failed attempts, the eblocker did what it was supposed to do for the first time on all mobile devices (ipads and iphones) as well as on my iMac. Thanks to your hints. The function test under "Status" did not show any errors for the first time. Both "Tracer" attempts were successful.

Unfortunately the joy was only of short duration.
As already described before: After some time the eblocker was no longer accessible and I could not go online. As soon as I restarted the eblocker everything worked again. 5 minutes later the same problem.

I will now have to follow up your hints about a hardware defect.
Before I check the hardware for errors:

Is it possible that the described error results from wrong settings in my Fritzbox?

If not, I will reinstall the eblocker completely after saving the settings (and without the old Settings). If that does not work I will buy a new SD first. If this does not lead to success either I will buy a new Raspi.

@all

But first of all I will now make a first donation to the eblocker project as I am very grateful that there are people who care about this important issue. A big thank you to all of you for your tireless efforts for this project.


Pio78, Benne and CalimerO liked
ReplyQuote
Member
Joined: 11 Monaten ago
Posts: 224
26/10/2020 8:39 pm  

@zwergkralle

Welcome to the eBlocker community 🙂

Can you tell us, which device you use for eblocker?

And do you use a standard powersupply or an replacement? 

Can you please tell us the powerdelivery data of the powersupply?

Something like "5 volt, 2 Ampere" 

regards

Sven


ReplyQuote
Eminent Member
Joined: 9 Monaten ago
Posts: 28
26/10/2020 9:00 pm  

@calimero

Thank you,

I have a Raspberry Pi 3 Modell B+

with a Standard powersupply for Raspberry Pi, 5V, 2,5 A.


ReplyQuote
Member
Joined: 12 Monaten ago
Posts: 598
28/10/2020 8:55 am  

@zwergkralle As discussed: I fear this is not a software but a hardware issue. 

Can I consider the network config question „solved“ and close this topic?

If your issue persists after switching SD & power supply, you are welcome to add again to this thread and I „unsolve“ the topic again.

THX - also for your support!


ReplyQuote
Eminent Member
Joined: 9 Monaten ago
Posts: 28
28/10/2020 10:33 am  

@random

yes, that's ok. THX


ReplyQuote
Scroll to Top