Please check out the new Instant Help (beta) first before posting.

Notifications
Clear all

[Solved] Receiver Radio behaves strange


Estimable Member
Joined: 1 Jahr ago
Posts: 248
Topic starter  

iMac macOS 11.2.3, iPad 5e gen. iPadOS 14.4.2, eBlocker White Cube eOS 2.6.2

   Not so sure whether this issue belongs here, but the issue involves eBlocker ...

Installed the app 'Radio Receiver from 'mamp GmbH' ( https://www.mamp.info/receiver/de/) both on my iPad and my iMac. Made a setup with a list of radio-station as shown in the enclosed screenshot. (synced trough iCloud)

IMG 1459
Schermafbeelding 2021 04 21 om 16.05.35

 

When i start listening to the first internet-radiostation, NPO Radio 1, after a minute or so the app switches automagically to the next station on the list 'NPO Radio 4 Concerten'. After again a minute or so the app switches to 'Klara Continuo (VRT)' and again, after a minute or so it switches to 'Radio Classique' and so forth. It works down the list of stations until it has reached 'WQXR 105,9' (a New York classical station) and there it stops for unknown reasons. This strange behaviour appears when eBlocker is switched ON. Both iMac and iPad are set to use HTTPS and the dashboard of both devices show 2 green checkmarks for HTTPS-support and only green checkmarks for all the 5 tests in Status.

Now, when eBlocker is paused or the devices are switched off in the device-list of Settings, the app 'Receiver Radio' behaves as it should; both on the iPad and the iMac, NO nonsense and NO magic switching!

I made 3 separate recordings in Settings/HTTPS/MANUAL RECORDING each of 15 minutes, both for my iMac and on my iPad. For all of the gathered connections, i set the 'Temporary rule' for each and every Domain to 'eBlocker disabled' (regardless which domain was recorded, regardless 'goodies' or 'baddies') and then saved all separate recordings to the TRUSTED APPS list with different names; so eBlocker should recognise, and allow acces to, each and every domain recorded during all of the various recordings.

As long as eBlocker is switched ON (respecting all the rules in TRUSTED APPS), Receiver continues to behave strange. As soon as eBlocker is switched OFF, the 'Receiver Radio' app behaves well.

The one domain that always should be allowed by eBlocker is 'airable.io' as it provides acces for the 'Receiver' app to the database of internet-radio-stations, maintained by 'airable GmbH' ( https://www.airablenow.com)

Most probably i am one of the (very?) few people who use both eBlocker AND 'Receiver Radio', the reason for my doubt at the beginning of this topic.

Rob


Quote
Member
Joined: 1 Jahr ago
Posts: 891
 

I suppose your eBlocker is running in Automatic Network mode. Then this is a known behavior that can be fixed by setting eBlocker to Individual Network mode.

See also here:

https://eblocker.org/community/bugs-features/internet-radio-playback-stops-after-a-short-time/

https://eblocker.org/docs/information-on-radios-loudspeakers-printers-nas/

THX! 

 


ReplyQuote
Estimable Member
Joined: 1 Jahr ago
Posts: 248
Topic starter  

@random

Thanks for the reply and the info provided; it could well be the solution.

Actually, i found that i have 17 devices connected to my router, ranging from Macs and iDevices to NAS, SmartTV and an Air Conditioner. Rebooting all of them is a major operation 🙂

Have a nice day! Rob


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 891
 

@robfranssen-fr No need to reboot any device! This advice is for the impatient 😉 

You can just wait until the clients request the DHCP server anew. Usually within 24h. So the aircon will be set right in time 😀

To force this DHCP request (for the „urgently needed“ devices) you can also pull the LAN plug or dis- and re-enable by software (ie. flight mode) for WLAN. 

THX!


ReplyQuote
Estimable Member
Joined: 1 Jahr ago
Posts: 248
Topic starter  

@random

Problem solved, thank you for factual and moral support 😉

FRITZ!Box suggests...

If you would like to use a different DNS server in your home network, enter its IP address here so that the FRITZ!Box can announce it to the devices in the home network.

 
Is this a good idea or should i leave it alone?
Rob

ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 891
 

„Never touch a working system“ is a sysadmin‘s speech 😉
If your eBlocker is running well, there is no need for extra configuration elsewhere...

THX! 


ReplyQuote
Estimable Member
Joined: 1 Jahr ago
Posts: 248
Topic starter  

@random

Will do; thanks again.

Rob


Random liked
ReplyQuote

Scroll to Top