Please check out the new Instant Help (beta) first before posting.

Notifications
Clear all

[Solved] DNS Firewall test error


 Rudi
Active Member
Joined: 2 Monaten ago
Posts: 18
Topic starter  

Hello,

I bought a Rasp 4B and installed latest eBlocker version. 

Actually I've the following problem  :

1. For the a) DNS Firewall and b) PATTERN Blocker test there is no green ok arrow
    but a red exclamation mark ? ?  Get the following message every time I test

   a) Possible causes:
       Your device uses a cached DNS response. Please start the test again in a few     
       minutes

    b) Possible causes:
        The connection to your Internet provider is interrupted.

    

How can I solve these problems ? 

Client OS
Windows
Browser
other
eBlocker hardware
Raspberry 4 2GB+
Client OS version
Win 7
Browser version
latest OPERA ( Chrome )
eBlockerOS version
2.58

Quote
Topic Tags
Member
Joined: 1 Jahr ago
Posts: 855
 

Please share more infos about your setup: s.  https://eblocker.org/community/announcements/before-posting-here-please-read/#post-117

Please also share the output of a traceroute to www.eblocker.org as described here:

for mac https://eblocker.org/docs/check-the-network-connection-with-macos/

for pc https://eblocker.org/docs/check-the-network-connection-with-windows/

THX!


ReplyQuote
 Rudi
Active Member
Joined: 2 Monaten ago
Posts: 18
Topic starter  

Meanwhile after long testing and configuring I started from scratch .
Now I'm on the air aigain but things are nearly the same (TOR turned off  now) 

O.k. !  Here are my specs:

1. Raspberry                   : 4B - 2GB
2. eblocker                     : 2.58  List 47
3. network mode             : auto
3. network setting           : 192.168.178.77   255.255.255.0   192.168.178.1
4. Fritz Box                     :7590 , DHCP on , eblocker always .... .178.77
5. eBlocker DNS FW         : Custom list - from list in upper earlier post 
6. Client network             : 192.168.178.27  255.255.255.0    GW 192.168.178.1
7. HTTPS                        : ON, Zertifikat installed o.k.
8. Browser                      : Opera 74.0.3911.218  - latest version
9. TOR / VPN                   : OFF

After starting from scratch it took me a while to get eblocker to operate. A lot of time I spend  to find the location in the FB-7590 to activate or deactivate DHCP server. This is good hidden now in the FB-7590  ? ! 

I can operate eBlocker now but not all results are "green positive " in STATUS .This will not change while testing many times. 

eBlocker Status
tracert eblocker org
DNS custom list

As said I'm happy that's eblocker is alive now again  but I'm not sure that all is correct configured ?

But still two red exclamation marks in relation to the  DNS cache . How can I get rid of them ?  Can I have control of the DNS Cache ?

PS: I just read  some of the very good info on your web pages here and cleared the   cache of my browser.  Status  DNS Firewall now ok. 

eBlocker Status improved

In STATUS I've  always got  a  hint about  the DOMAIN Blocker !  Clearin DNS Firewall cache didn't help .


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 

Another user reported the 7590 not to be compatible with Automatic Network Mode: https://eblocker.org/community/bugs-features/connection-error-office-365-imap-account-with-eos-2-5-8-macos-11-2-2/#post-3399

Just a quick guess: maybe changing to Individual Network Mode helps here too? 

(I‘ll look into your post and the posted results tomorrow. Today my day is packed already).

THX!


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 

@rudi Can you please check if your client uses eBlocker DNS with the following on the command shell (cmd)

nslookup eblocker.org

Please post screenshot of result here.

THX!


ReplyQuote
 Rudi
Active Member
Joined: 2 Monaten ago
Posts: 18
Topic starter  

Hello Random 

that's the screenshot you wanted, eblocker turned on or off - same results . As you can see it's one of the servers from my DNS Firewall custom round robin list. FB-7590 has different ones.

nslookup not authorized
FB 7590 DNS servers

BTW tracert allways have the same ( false ?  ) results whether  DETAULT, TOR or Custom is selected :

tracert eblocker org no diff

 

 


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 

@rudi Please try to set eBlocker to Individual Network Mode. Your results show eBlocker is not routing properly in Auto Mode.

THX!


ReplyQuote
 Rudi
Active Member
Joined: 2 Monaten ago
Posts: 18
Topic starter  

Allthough I think that I've more  experience then the usual user of PC's and hardware aso , but  meanwhile I think I maybe messed up all and its better to  start  from scratch w 2.62  .

1.Is it necessary to switch FB-7590  to "  DHCP  OFF "  before first start  of 2.62 ?

2. Which IP adress for eblocker must or can I choose in manual mode ?  Where and when ?

    Install the mac and IP-ad in the FB-7590 list before fist start of 2.62 ?

3. Which gateway adress must I use in manual mode ?  Where an when ?

4. Are thers any modifications in 2.62 for  the use of the FB-7590 ?  

THX in advace.


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855

ReplyQuote
 Rudi
Active Member
Joined: 2 Monaten ago
Posts: 18
Topic starter  

I read these pages before but was surprised when my FB-7590 suddenly got a different IP adress. If you did'nt notice this you have to reset your FB. Lucky is  who had saved his settings.

I'll try it another time w. 2.62 now  and hope to get better results as before. 

BTW Had anybody checked what happend if " Another DNS " server was selected manually in the FB-7590, see picture, f.i. what happend if the eblocker IP ..168.178.88
is set there at the bottom edge of the picture ? 

FB 7590 weiterer DNS Server

ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 
Posted by: @rudi

Had anybody checked what happend if " Another DNS " server was selected manually in the FB-7590,

eBlocker takes over DNS (unless you deactivate it). So the fritzbox settings have no effect once eBlocker is active for your device.

THX!


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 

@rudi As you stated in your other post you’ve finally managed to get „all green“ in the tests. For other readers it would be nice if you could share here what the solution was. Individual mode? 

THX!


ReplyQuote
 Rudi
Active Member
Joined: 2 Monaten ago
Posts: 18
Topic starter  

No : " big surprise"  I'm running now in Automode. 

But it took a while , because at first automode messed up things , f. i. eBlocker had suddenly IP of Router or Router has IP adress of formerly ebBlocker's adress, sometimes switching while running without my influence ? 

Meanwhile I tried Expert mode , but was confused and didn'nt know where to set the adresses shown in the  lined box ? ?   In Automode the IP ad in the FB is  still the standard AVM ad  . . . 178.1 

 

eblocker expert mode

I reset and shut down , new start . I think I better followed the  instructions this time.  All but the 
HTTPS filtering then  was o.k.  It took a while still I find the correct folder to install the Zertifikate there. With this problem it seems to me I'm not allone, bcs a friend of mine had same Zertifakat installing problems.

On another Win-10 Notebook I still fight this battle althoug I did is succesfull in Opera and Firefox on the WIN PC   ? ? ! !  🙂 

Thx  - Keep healthy ! 

 

 


Random liked
ReplyQuote

Scroll to Top