Please check out the new Instant Help (beta) first before posting.

Notifications
Clear all

Passepartout VPN client & eBlocker Mobile issue


Active Member
Joined: 6 Monaten ago
Posts: 14
Topic starter  

Hello,

thank you for the new eblocker version. It works smooth.

After the first tests i have found a problem with eblocker mobile for my personal setup.

I am using the passepartout openvpn client for ios. This client allows to define trusted networks. That means the vpn connection starts as soon as i leave my home or work wifi.

With the actual eblocker version there is no vpn connection with passepartout possible, because eblocker uses compression (see screenshots). According to the developers VPN Compression is a security risk and should not be enabled.

Would you please check this and consider to stop vpn compression, or make it optional?

thx

IMG 0702
IMG 0701

 

Client OS
iOS
Browser
Safari
eBlocker hardware
Raspberry 4 2GB+
Client OS version
14.4
Browser version
14.0.3
eBlockerOS version
2.6.2

Quote
Member
Joined: 1 Jahr ago
Posts: 232
 

Hi Kalle,

look at the Release Notes:

https://eblocker.org/docs/release-notes-2-6/

eBlocker Mobile OpenVPN configuration so that deprecated compression directives don’t cause warnings with OpenVPN apps.

Could you test the original OpenVPN App ?

 

regards

PIO78

 


ReplyQuote
Active Member
Joined: 6 Monaten ago
Posts: 14
Topic starter  

Hi Pio78,

the original Openvpn App works, but does not have the super-cool feature of the trusted networks, so you have to activate it manually.

I have read the release notes, maybe i did not get right the changes  😉

Until version 2.5.8 eBlocker mobile and the passepartout app did work perfectly together, sadly it is broken now.

Do you have any hint how to solve this?

thx


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 
Posted by: @kalle

With the actual eblocker version there is no vpn connection with passepartout possible, because eblocker uses compression (see screenshots). According to the developers VPN Compression is a security risk and should not be enabled.

eBlocker 2.6 uses no compression! Make sure you setup eBlocker Mobile anew to get the latest openvpn config.

THX.


ReplyQuote
Active Member
Joined: 6 Monaten ago
Posts: 14
Topic starter  

Hi Random,

please take a look at the sceenshot of the logfile.

According to this it seems that you are using the openvpn option:

"Disable Compression, retain compression packet framing (compress)", correct?

Unfortunately passepartout classifies this as compression.

(I made a fresh install, after noticing this effect...)

cu


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 

@kalle Have you tried editing the ovn file to remove any options that your client may consider as „compression“? I‘m on win and can not help with macOS unfortunately...

THX!


ReplyQuote
Active Member
Joined: 6 Monaten ago
Posts: 14
Topic starter  

@random

i took a look at the opvn file, but the mentioned option is given by the server config.

Do you have a hint how to edit this file?

thx


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 81
 

@kalle, @random, @pio78

I think the problem is that Passepartout does not understand all OpenVPN options. It seems to be confused by the Option "compress stub-v2" which is pushed by the server and which should actually disable the compression (in case the client has an older configuration that was created with eOS 2.5).

I have written an issue about this: https://github.com/eblocker/eblocker/issues/107

We could remove the server push, but I think that all existing client configurations would then have to be re-created with 2.6 and re-installed on the clients.


ReplyQuote
Active Member
Joined: 6 Monaten ago
Posts: 14
Topic starter  

@Boris

thanks for looking into this.

I have contacted the developer of passepartout as well an sent him the link to this topic.

Definetely i will not urge you to change this if i am alone.

Maybe there will be others with a similar effec...

cu

Kalle


ReplyQuote
New Member
Joined: 3 Wochen ago
Posts: 1
 

I have the same problem described above. I think it would be great if a user could adjust the settings in eBlocker manually (HMI) if needed.
Thanks for your help, I find the eBlocker really great (testing it since a few) weeks.


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 

@grisu_manfred @kalle I take your point - but as @bpr discussed: a change for passepartout would mean all other eBlocker Mobile users need to reinstall a new config. So we would make 99,x% of our users unhappy to turn <1% happy. 🤔 

Personally I doubt it's a good idea to make this a quick change. At the current time I'd rather recommend to use the original OpenVPN client - and live with less features 😉

THX! 


ReplyQuote
Active Member
Joined: 6 Monaten ago
Posts: 14
Topic starter  

@Random @bpr

I have made a lot of tests with openvpn and pivpn in the last couple of months (for other solutions).

As far as i learned a change of the server config should have no effect to the existing clients, the only case would be if a client e.g. expects to get lz4 compression, where the server does not offer this but pushes compression.

In eblockers client config file there is no entry for compression, so i do not expect effects on a change on the server side.

Maybe you could make a test? That would be great.

 

thx


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 

@kalle eBlocker is a community project where people who see the need for a change/improvement engage with the team to make it happen.

So I suggest you join the team to verify your thoughts and help other passepartout users, rather than hoping for someone else to "make a test" for you. I fear it's not a priority otherwise as this improvement only affects a very small minority...

Hope to welcoming you soon!

THX!


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 855
 

@kalle From the lack of feedback to my invitation, I understand you have no time for supporting the passepartout issue to help other users like @grisu_manfred. Sad. Then I fear this issue will not get solved as no one else in the team is using passepartout (and it‘s probably not a bug in eBlocker but in passepartout)...

THX anyway!


ReplyQuote

Scroll to Top