Please check out the new Instant Help (beta) first before posting.

Notifications
Clear all

[Solved] Can't enter a license because there is no internet connection.  


Active Member
Joined: 2 Monaten ago
Posts: 7
Topic starter  

Hello everyone.

First of all thank you for your commitment.
I'm new to eblocker and I'm having a problem with the installation. I can't enter a license because there is no internet connection.

Yes, I have read the corresponding articles here.
Yes, the eblocker client (a Raspi 2) has full access to the internet.
No matter what I do it does not like. And unfortunately I can't get anywhere like that.
What I also noticed unpleasantly is that eblocker blocks the network to the internet in the default setting dhcp, even if you haven't made any settings.
Is this intentional?

My version: 2.5.6
Router: Fritzbox 7530

Are there any earlier versions available for download?

Many greetings
hobin


Quote
Member
Joined: 1 Jahr ago
Posts: 683
 
Posted by: @hobin_rood

I can't enter a license because there is no internet connection.

How do you come to this conclusion? What‘s the error message you are getting?

Posted by: @hobin_rood

What I also noticed unpleasantly is that eblocker blocks the network to the internet in the default setting dhcp, even if you haven't made any settings.

Same question here. What makes you think this is the case? 

Would be great to see screenshots of errors AND all the infos asked here

THX!


ReplyQuote
Active Member
Joined: 2 Monaten ago
Posts: 7
Topic starter  

Hello Random.

Sorry if I disregarded the rules. That was not my intention.
I will provide the necessary information tomorrow.

Greetings
hobin


Random liked
ReplyQuote
Active Member
Joined: 2 Monaten ago
Posts: 7
Topic starter  

Hello.
Here is my answer to the standard questions:

Hardware you use for running eBlockerOS
--> Raspberry Pi 2 B V1.1
eBlockerOS version as well as filter lists version
--> 2.5.6
eBlocker network mode (auto, individual or expert)
--> auto
eBlocker network settings (IP, mask, gateway)
--> xxx,xxx.177.243, C-Class, GW ...177.1
eBlocker DNS firewall settings
--> couldn't see settings
Client network settings (IP, mask, DNS, gateway)
--> xxx.xxx.177.203 , other same as eBlocker
Whether eBlocker's https integration is enabled for client
--> couldn't set because no License Activation
Client browser and OS version (i.e. FireFox 80.1 running on macOS 13.4)
--> Firefox and Chrome running on Kubuntu 18.04 (Bionic) Kernel 4.15.0-122-generic

I also reinstalled the eBlocker again to be on the safe side.
The second point, that the internet access is blocked, is no longer given (no idea what the problem was).
I still can't enter a license because I can't load the license agreement (see screenshot).

The Raspi has unlimited access via the router (FB 7530)

 Auswahl 150

ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 683
 
Posted by: @hobin_rood

The Raspi has unlimited access via the router (FB 7530)

Are you sure eBlocker has Internet access? Error message indicates that it's not the case.

Some ideas to check:

  • If you are using MAC/hardware address blocking on your router (i.e. for new devices), please disable fully.
  • Make sure eBlocker's IP address (see in your router) is not being blocked by some "Internet filter" of the router.
    • And it's a good idea to assign always the same IP to eBlocker in your routers DHCP settings. But that's more for the future once it's running well.
  • Last idea: Change the LAN port of your router where you plug in the eBlocker. Depending on router config there might be a port configured not to get Internet access (guest port or such)

If all this fails - I have no clue. Sorry.

For sure it's not an eBlocker issue but the cause is somewhere in your network configuration...

THX!

 


ReplyQuote
Active Member
Joined: 2 Monaten ago
Posts: 7
Topic starter  

Hello.
Thanks for the answer.

-If you use MAC/hardware address blocking on your router (e.g. for new devices), please disable it completely.
No, is not active. It also says "unrestricted".

- Make sure that the IP address of the eBlocker (see in your router) is not blocked by any "Internet filter" of the router.
Nothing is filtered at the moment. But I will check it again.

-And it is a good idea to always assign eBlocker the same IP in the DHCP settings of your router. But this is more for the future, if it works well.
Is set like this anyway.

- Last idea: Change the LAN port of your router where you connect eBlocker. Depending on the configuration of your router, there may be a port that is configured so that no Internet access is possible (guest port or similar).
Yes, I have to test this. But I have connected everything via one port.
Via another 3 unmanaged switches.

I will probably test with Wireshark as well.

Greetings
hobin


ReplyQuote
Active Member
Joined: 2 Monaten ago
Posts: 7
Topic starter  

Hello everyone.
I have now done some tests.

To exclude my network I have a test setup with an LTE laptop, a switch, an eblocker and a client in this network.
Also here I could not get a license. But the additional client as test station had unlimited access.

Then I put Wireshark on the interface.
This "told" me that the eblocker answered with the http error 500 when trying to get the license. To be on the safe side, I reloaded the SD card with the original image. Also after that the error occurred.

Finally I downloaded the image again. And after that there were no more problems.
A little bit strange, because I don't expect that a download "error" will influence such things (in this case the image as such should not run).
Or a new version was made available for download?

But in the end it does not matter. Now it works for now.
Thanks for the support.

Greetings
Hobin


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 407
 
Posted by: @hobin_rood

Or a new version was made available for download?

Where did you get your image? What version was this (see filename)?

With the open source release the end user license is new (EUPL of course 😎). So I suspect the old commercial license agreement can not be loaded anymore...

Not a wanted effect (in terms of user experience) but rather a feature than a bug. The commercial license with eBlocker GmbH can no longer be used (as the company has ceased business). But with the right image eBlocker will be revived in the Open Source world 😍 😎 😀 

Summary for readers: If the license agreement is not shown, make sure you have the latest images and eBlocker has full Internet access.


ReplyQuote
Active Member
Joined: 2 Monaten ago
Posts: 7
Topic starter  
Posted by: @benne

Where did you get your image? What version was this (see filename)?

I've downloaded this

https://eblocker.org/eblockeros-download/eBlocker-2.5.6-raspberry-pi-4.img.gz

Greetings

hobin


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 683
 

 @hobin_rood Very strange - not to say „a wonder“.

Are you 100% sure this was the image you‘ve used initially?

Can you please make a diff/cmp of the two images (as you are a tech guy😃). I wonder if the image was not fully downloaded how it could have ever been decompressed during the SD install... 🤔 

THX!


ReplyQuote
New Member
Joined: 1 Monat ago
Posts: 3
 

No I build a new eBlocker-device with OS 2.5.6. By activating I receive the message "Unable to load license agreement. An Internet connection is required."

In the network mode I tried both individual and Automatic Network Mode.

In the devices list I see all devices with the correct IP adress, this means, the eBlocker works correct in the LAN.

My router is a Fritz!Box Cable 6490, I fixed the IP of the eBlocker. The previous device with the old OS worked fine.

I tried different browsers with no effect.

Does anyone have an idea?

Thanks and kind regards
Detlef


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 683
 

@detlef-ac I've joined your topic to this thread as it probably answers your question.

Personally I'm not sure how you can access the devices / settings without accepting the license agreement... 🤔 

You might want to use the search function (in the left hand side bar) as there are other "can't enter license" topics (if I remember right) which are solved already and might be useful...

THX!


Pio78 liked
ReplyQuote
Active Member
Joined: 2 Monaten ago
Posts: 7
Topic starter  
Posted by: @random

 @hobin_rood Very strange - not to say „a wonder“.

Are you 100% sure this was the image you‘ve used initially?

Can you please make a diff/cmp of the two images (as you are a tech guy😃). I wonder if the image was not fully downloaded how it could have ever been decompressed during the SD install... 🤔 

THX!

Sorry for the late reply.
Unfortunately no. I don't have the previous file as a comparison possibility anymore.

 

greetings

hobin


ReplyQuote
New Member
Joined: 1 Monat ago
Posts: 3
 

Now I've seen in the expert modus of network settings, there are wrong IP's für the external DHCP-Service, these are the IP's of the eBlocker. I expect the Gateway-IP for the DHCP-Service.

The DHCP-IP are not editable.

ksnip 20201208 194615

Thanks to Random for moving my topic to this thread.


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 197
 

@Detlef-AC

in "Expert-Mode" you can not edit these setting. You have to tell your DHCP Server that the DHCP-Server give the Client the Gateway and DNS. The Gateway and DNS is then eBlocker, so all Internettraffic will go to the eBlocker.

 

You have a Fritzbox, so you can’t choose "Expert-Mode". Best for Cable Box is "Individual Mode"

See Tims Video on Vimeo for configuration:

https://vimeo.com/user92153728

Look this and it will help you... 🙂 

 

regards

PIO78

 

 


ReplyQuote
Member
Joined: 1 Jahr ago
Posts: 683
 

@detlef-ac If you set the eBlocker to use an external DHCP server this (external) DHCP server needs to be configured with the configuration shown in the box. Usually this is only possible with separate external DHCP servers not with router DHCP services.

I‘m not sure what you try to achieve but to me it appears you have no idea of what you are doing. Sorry. Setting eBlocker to expert mode is for, right: experts (in network configuration). If you are not an expert, please stop using this mode!

In case your router is the DHCP server, please set eBlocker back to Auto Network Mode and make sure no MAC address blocking in your router is taking place (which might be the reason eBlocker get‘s no Internet access). Also make sure you have the current eOS image from our website, not from other sources (see posts above).

THX! 


ReplyQuote
New Member
Joined: 1 Monat ago
Posts: 3
 

After the mode individual and automatic didn't work in the network configuration, I chose the mode expert for testing, now I switched back to automatic mode. But without success.

I also repeated the download from eblocker.org and rebuilt the OS with balenaEtcher-1.5.111-x64.

There are no locks or filters in the router.

Since January 2019 I use the wonderful eBlocker. In my network there have been no changes. Only with the new OS 2.5.6 the described problem occurred to me.


ReplyQuote
New Member
Joined: 1 Woche ago
Posts: 1
 

Hello,

Had the same issue. I needed to unplug and replug my raspberry for it to work. hope that helps

 

 


Random and Benne liked
ReplyQuote
Scroll to Top